Openwrt 允许多播流量
Openwrt allow multicast traffic
我在设备上 运行 openwrt,并且有一个 python 脚本可以侦听和打印以筛选 239.2.1.1 上的多播流量。
但是屏幕上没有打印任何内容,我认为这是防火墙问题。
我如何确保在 lan 接口 运行 openwrt 上允许多播流量?
我知道有点晚了,但我想这会对仍在寻找答案的人有所帮助。
安装 IGMPProxy
install igmpproxy
make menuconfig
-> Network
-> Routing and Redirection
在 bin 文件夹中查找包
AR9331 hardware:- bin/ar71xx/packages/base/igmpproxy_0.1-9_ar71xx.ipk
copy the ipk to openwrt router.
opkg install igmpproxy
/etc/init.d/igmpproxy start
确保您在 /etc/config/firewall
中找到了此部分
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
确保你在 /etc/config/igmpproxy
中找到了这一部分
config igmpproxy
option quickleave 1
config phyint
option network wan
option direction upstream
list altnet 0.0.0.0/0
config phyint
option network lan
option direction downstream
确保网络配置中的以下内容
In /etc/config/igmpproxy
config interface lan
option igmp_snooping 1
在 br-lan 中也启用
echo "0" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping
我在设备上 运行 openwrt,并且有一个 python 脚本可以侦听和打印以筛选 239.2.1.1 上的多播流量。
但是屏幕上没有打印任何内容,我认为这是防火墙问题。 我如何确保在 lan 接口 运行 openwrt 上允许多播流量?
我知道有点晚了,但我想这会对仍在寻找答案的人有所帮助。
安装 IGMPProxy
install igmpproxy
make menuconfig
-> Network
-> Routing and Redirection
在 bin 文件夹中查找包
AR9331 hardware:- bin/ar71xx/packages/base/igmpproxy_0.1-9_ar71xx.ipk
copy the ipk to openwrt router.
opkg install igmpproxy
/etc/init.d/igmpproxy start
确保您在 /etc/config/firewall
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
确保你在 /etc/config/igmpproxy
中找到了这一部分config igmpproxy
option quickleave 1
config phyint
option network wan
option direction upstream
list altnet 0.0.0.0/0
config phyint
option network lan
option direction downstream
确保网络配置中的以下内容
In /etc/config/igmpproxy
config interface lan
option igmp_snooping 1
在 br-lan 中也启用
echo "0" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping