需要帮助在 Cisco 2600 上创建路由 (IOS 12)
Need help creating route on Cisco 2600 (IOS 12)
就 IP 地址而言,我已经配置了 Cisco 2600,但不太熟悉 IOS 我在创建两个网络之间的路由时遇到了一些问题。
我只需要在端口 47808 上路由数据。我希望路由器阻止所有其他流量。这需要是真正的路由,而不仅仅是桥接两个网络。
我已经尝试了很多不同的,所以配置可能有一些 "anomalies" 所以在这里添加。我当前的 运行 配置:
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
ip subnet-zero
ip domain-name software
!
ip cef
ip audit notify log
ip audit po max-events 100
cns event-service server
!
process-max-time 200
!
interface FastEthernet0/0
ip address 10.222.51.235 255.255.252.0
no ip directed-broadcast
no ip mroute-cache
speed 100
full-duplex
no mop enabled
bridge-group 1
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface FastEthernet0/1
ip address 10.222.52.254 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
speed 100
no mop enabled
bridge-group 1
!
router igrp 1
redistribute connected
network 10.0.0.0
!
ip classless
ip default-network 255.255.255.255
ip forward-protocol spanning-tree any-local-broadcast
ip forward-protocol turbo-flood
ip forward-protocol udp 47808
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
bridge 1 protocol dec
bridge 1 address 0010.0222.0051 forward FastEthernet0/1
bridge 1 address 0010.0222.0053 forward FastEthernet0/1
我愿意接受所有关于清理和正常工作的建议。
路由器会自动为您在接口上配置的每个网络创建一个连接路由,因此路由不是该路由器上两个网络之间的问题。为确保来自一个网络的流量被路由到另一个网络,您首先需要确保流量被路由到该路由器。如果此路由器不是任一网络的默认网关,您将需要在每个网络的默认网关上添加静态路由。
在 10.222.48.0/22 的默认网关上,您需要添加以下路由。
ip route 10.222.52.0 255.255.255.0 10.222.51.235
在 10.222.52.0/24 的默认网关上,您需要添加以下路由。
ip route 10.222.48.0 255.255.252.0 10.222.52.254
如果您只想将流量限制到一个 tcp 端口,您需要将扩展访问列表应用于接口。由于这是一个非常旧的路由器,它可能不支持扩展的访问列表,所以这可能不起作用。
示例访问列表:
ip access-list extended allow47808
permit tcp any any eq 47808
deny ip any any
然后您需要将访问列表应用到接口
int fa0/0
ip access-group allow47808 in
ip access-group allow47808 out
int fa0/1
ip access-group allow47808 in
ip access-group allow47808 out
如果您执行所有这些操作,您很可能只会获得单向流量,因为对 tcp 请求的回复将在不同的端口上并被阻止。您也将无法通过 telnet 或 ssh 连接到路由器,因为访问列表也会阻止该流量,您将需要通过控制台连接到它。鉴于您提供的信息,这是我能做的最好的。
就 IP 地址而言,我已经配置了 Cisco 2600,但不太熟悉 IOS 我在创建两个网络之间的路由时遇到了一些问题。
我只需要在端口 47808 上路由数据。我希望路由器阻止所有其他流量。这需要是真正的路由,而不仅仅是桥接两个网络。
我已经尝试了很多不同的,所以配置可能有一些 "anomalies" 所以在这里添加。我当前的 运行 配置:
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
ip subnet-zero
ip domain-name software
!
ip cef
ip audit notify log
ip audit po max-events 100
cns event-service server
!
process-max-time 200
!
interface FastEthernet0/0
ip address 10.222.51.235 255.255.252.0
no ip directed-broadcast
no ip mroute-cache
speed 100
full-duplex
no mop enabled
bridge-group 1
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface FastEthernet0/1
ip address 10.222.52.254 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
speed 100
no mop enabled
bridge-group 1
!
router igrp 1
redistribute connected
network 10.0.0.0
!
ip classless
ip default-network 255.255.255.255
ip forward-protocol spanning-tree any-local-broadcast
ip forward-protocol turbo-flood
ip forward-protocol udp 47808
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
bridge 1 protocol dec
bridge 1 address 0010.0222.0051 forward FastEthernet0/1
bridge 1 address 0010.0222.0053 forward FastEthernet0/1
我愿意接受所有关于清理和正常工作的建议。
路由器会自动为您在接口上配置的每个网络创建一个连接路由,因此路由不是该路由器上两个网络之间的问题。为确保来自一个网络的流量被路由到另一个网络,您首先需要确保流量被路由到该路由器。如果此路由器不是任一网络的默认网关,您将需要在每个网络的默认网关上添加静态路由。
在 10.222.48.0/22 的默认网关上,您需要添加以下路由。
ip route 10.222.52.0 255.255.255.0 10.222.51.235
在 10.222.52.0/24 的默认网关上,您需要添加以下路由。
ip route 10.222.48.0 255.255.252.0 10.222.52.254
如果您只想将流量限制到一个 tcp 端口,您需要将扩展访问列表应用于接口。由于这是一个非常旧的路由器,它可能不支持扩展的访问列表,所以这可能不起作用。 示例访问列表:
ip access-list extended allow47808
permit tcp any any eq 47808
deny ip any any
然后您需要将访问列表应用到接口
int fa0/0
ip access-group allow47808 in
ip access-group allow47808 out
int fa0/1
ip access-group allow47808 in
ip access-group allow47808 out
如果您执行所有这些操作,您很可能只会获得单向流量,因为对 tcp 请求的回复将在不同的端口上并被阻止。您也将无法通过 telnet 或 ssh 连接到路由器,因为访问列表也会阻止该流量,您将需要通过控制台连接到它。鉴于您提供的信息,这是我能做的最好的。