柯里化函数中第一个函数的命名约定

naming convention for the first function in curried functions

像这样的柯里化函数是否有命名约定:

const someName = argA => argB => ...
const newFunction = someName(someArg)

someName 的声明有命名规则吗?比如在它前面加上 init / create 等?

你可以取一个描述性的命名,比如

const
    multiplyBy = a => b => a * b,
    multiplyWith5 = multiplyBy(5);

var array = [3, 14],
    result = array.map(multiplyWith5);

我喜欢使用尾部下划线:const curriedFunction_ = () => () => {} 这样它表示不同之处。