Mikrotik - 路由脚本

Miktotik - routing script

我一直在做这个脚本。脚本应该这样做:

它将从 URL 下载一个文件。如果它到达文件并下载它,然后更改到服务器 1 的路由。如果下载失败,它将更改到服务器 2 的路由。然后它将从路由器内存中删除该文件。

Download should be via command: /tool fetch url="" and then something like
 :if ( true ) do (/ip routing .....) 
and 
:if ( false ) do (/ip routing ....) 

我希望你能理解我并帮助我创建这个脚本。

制定 2 个每 hour/10mins 重复一次的计划(由您决定),并根据文件大小或连接速度将开始时间间隔 10 秒或更长时间。

第一个脚本删除现有文件并重新下载它:

/file remove index.php
/tool fetch url="http://example.com/index.php"

第二个检查文件是否存在:

:if ([/file find name=index.php]="") do={
#commands if download was not succesful and file does not exist
} else={
#commands if download was succesful and file exists
}